French English German Italian Russian Spanish

Nous allons nous intéresser au Passage de Joomla 2.5 de la version php 5.3 à la version php 5.4

Mais attention suivant vos extensions vous pouvez avoir d'autres problèmes que celui ci dessous, un conseil essayez de les supprimer pendant que vous pouvez car si ces applications plugin, composants ou modules ne sont plus maintenus, les versions jusqu'à php 7 seront de plus en plus dur à mettre à jour.

Parse error: syntax error, unexpected ‘=’, expecting ‘(’ in /www/includes/framework.php on line 42

--> Il suffit de commenter la ligne 42 du fichier framework ainsi :

Au lieu de :

JError::$legacy = true;

On remplace par :

//JError::$legacy = true;